The deployment to our production environment has been completed successfully. All systems are operating as expected.
Posted Feb 25, 2026 - 05:03 PST
In progress
We are currently deploying updates to our production environment. The deployment is in progress and proceeding as planned.
Updates will be shared here until the deployment is complete.
Posted Feb 25, 2026 - 03:12 PST
Scheduled
A deployment to our production environment is scheduled for 02-25-2026 between 3:00–4:00 AM PST.
SimpliGov Version 2.2.0 is being deployed to Production. This release focuses on itemized surcharges and convenience fees across Designer and Requestor experiences, ensuring consistent fee calculation and display across workflows, checkout, receipts, and totals. It also updates UI naming from CMS (Case Management System) to SM (Service Management) and adds configuring Role-Based Access Control (RBAC) for Accounts and Case Template Management.
Additional updates will be shared here as the deployment begins.
Posted Feb 25, 2026 - 02:42 PST
This scheduled maintenance affected: SimpliGov - Production (Portal).