Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2025 - 05:15 PST
Scheduled
New Features & Enhancements
Send Documents as Base64 in External API Requests
SimpliSign now automatically converts signed documents and audit trails into Base64 for use in External API calls, enabling direct transmission of PDF content through JSON without additional processing.
Field Conditions for Dynamic Document Logic
Designers can now create rules that show or hide fields based on user input, improving document flow, ensuring proper completion order, and enhancing user experience.
Enhanced Delegation Dialogue for Batch Sign
Users can delegate multiple documents more efficiently with grouped views, auto-fill for registered users, a “Delegate all to the same user” option, and customizable notification messages.
🔧 Additional Enhancements
Added Owner Rejected notification to distinguish sender cancellations from signer declines.
Introduced Redacted Audit Trail output to hide personal data (name, email, IP) for compliance and secure sharing.
Implemented a dedicated loading skeleton for the unauthenticated Sign page.
Updated cancellation emails for accuracy and clarity.
Updated delegation pop-ups with a consistent “Delegate” button.
Added a document-level switch for showing signer email & date in signature stamps.
Displayed Signer Groups in Profile → Permissions for improved admin visibility.
🐞 Bug Fixes
Resolved an issue where forms remained in a perpetual loading state after clicking Submit, restoring normal submission behavior.
⚙️ Deprecated / Removed Functionality
No features were deprecated or removed in this release.