The deployment to our pre-production environment has been completed successfully. Validation and testing are underway to confirm readiness for production.
We are currently targeting Production deployment in two weeks.
Posted Jan 27, 2026 - 07:41 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 27, 2026 - 03:00 PST
Scheduled
A deployment to our pre-production environment is scheduled for January 27 between 3:00–5:00 AM PT.
This release contains internal platform/modernization updates only. There are no customer-facing feature changes included. Additional updates will be shared here as the deployment begins.
A production deployment is planned approximately two weeks after this pre-production release, pending successful testing and validation.
Posted Jan 26, 2026 - 14:16 PST
This scheduled maintenance affected: SimpliGov - Preproduction (Portal).